Google login issues

Incident Report for Cloud 66

Resolved

The underlying issue with GCP seems to be resolved, and we are not seeing further issues with the logins and other systems.
Posted Jun 12, 2025 - 20:30 UTC

Investigating

Google authentication issues is having issues causing login and access issues for our systems and customers. We are investigating the impact and mitigation strategies.
Posted Jun 12, 2025 - 19:09 UTC
This incident affected: Cloud 66 Dependencies (Google Cloud Platform Google Kubernetes Engine, Google Cloud Platform Google Compute Engine, Google Cloud Platform Google Cloud Storage, Google Cloud Platform Google Cloud SQL, Google Cloud Platform Google Cloud Networking) and Core Systems.