DigitalOcean servers unable to pull BuildGrid images

Incident Report for Cloud 66

Update

GCS confirmed that an internal issue is causing the DigitalOcean IPv6 range to be blocked, and is currently working on a resolution.
Posted Aug 24, 2026 - 19:24 UTC

Identified

DigitalOcean's IPv6 range appears to be blocked from accessing Google Cloud Storage. This means CSv1 and CSv2 customers who have servers with public IPv6 addresses are currently unable to pull new BuildGrid images onto their servers.
Posted Aug 24, 2026 - 19:08 UTC
This incident affects: Cloud 66 Dependencies (Google Cloud Platform Google Cloud Storage).